FishStatJ Manual
Citation and disclaimer to be provided through PWS
CONTENTS

1. About FishStatJ ................................................................. 1
2. Installation ................................................................. 2
  2.1. Installing on Windows ................................................. 2
    2.1.1. Windows requirements ........................................ 2
    2.1.2. 32bit Windows installer ..................................... 2
    2.1.3. Using Windows auto-extract installer .................. 3
    2.1.4. Do not move or rename files .............................. 3
    2.1.5. Adding FishStatJ to the Taskbar ......................... 4
  2.2. Windows troubleshooting ........................................... 5
    2.2.1. Installation issues ............................................. 5
    2.2.2. How to check if your computer supports 64-bit ..... 5
    2.2.3. Diagnostic reporting ......................................... 6
  2.3. Installing on macOS ................................................ 7
    2.3.1. macOS requirements ......................................... 7
    2.3.2. Installation ...................................................... 7
    2.3.3. Authorization .................................................. 8
  2.4. macOS troubleshooting ............................................ 9
    2.4.1. Diagnostic reporting ......................................... 9
  2.5. FishStatJ Privacy Policy ......................................... 10
  2.6. Workspaces (statistical data) ................................. 11
3. File Menu ................................................................. 12
  3.1. Manage workspaces ............................................... 12
    3.1.1. Installing a new workspace (download) ............... 14
    3.1.2. Deleting a workspace ...................................... 19
    3.1.3. Importing a workspace ................................... 19
  3.2. Open Dataset ....................................................... 23
  3.3. Close workspace .................................................. 24
  3.4. Export selection (CSV file) ..................................... 25
  3.5. Exit 26
4. Data display ............................................................ 27
  4.1. Displaying a dataset .............................................. 27
  4.2. Notes (if applicable) ............................................ 28
  4.3. Toolbar icons ....................................................... 29
  4.4. Row Details ........................................................ 29
  4.5. Number of rows ................................................... 29
  4.6. Memory Status ..................................................... 29
5. Edit Menu ............................................................... 30
  5.1. Select all ............................................................ 30
  5.2. Select none ........................................................ 31
  5.3. Copy selection ..................................................... 32
  5.4. Preferences ........................................................ 33
    5.4.1. General preferences ....................................... 34
    5.4.2. Data display .................................................. 35
    5.4.3. Data display – Number formatting ..................... 36
    5.4.4. Data display – Symbols and Colors .................... 37
1. About FishStatJ

FishStatJ is a desktop application designed to disseminate FAO fishery statistical data to the world. FishStatJ's primary aim is to display, refine and export data. However, unlike a spreadsheet software it cannot modify the data, create graphs or perform advanced data analysis. One of FishStatJ's greatest strength is that it can display species according to several authoritative classifications, such as the International Standard Statistical Classification of Aquatic Animals and Plants (ISSCAAP) or the UN's Central Product Classification (CPC); and show the scientific name.

At the 23rd CWP meeting (2010), the prototype of FishStatJ was endorsed for full development and the first release of FishStatJ was delivered in 2011. FishStatJ is built using the Eclipse Rich Client Platform (Eclipse-RCP) tools. As such, it is a Java application, and requires that Java is installed on the computer. RCP allows to develop general purpose applications, which run on Windows and macOS.

FishStatJ build and improves on the features of FishStatPlus (its predecessor):

- all Fishery reference data is available (all FAO code lists with all attributes);
- all hierarchies are available (for view, and for filtering/aggregation);
- calculated columns of FishStatPlus are included;
- the software is cross-platform (Windows, Macintosh);
- data (workspaces) of dimensions can be defined as needed (flexible); and
- any data with fixed dimensions and yearly resolution can be loaded.

For the creation of workspace files (database files), a separate software called “FishStatJ Console” was developed.

In order to use the statistical data, the user has to download and install the FishStatJ application on his computer (more details follow).
2. Installation

2.1. Installing on Windows


FishStatJ - Software for Fishery and Aquaculture Statistical Time Series

FishStatJ is a Windows and Mac application that anyone can use to access FAO’s Fisheries and Aquaculture statistics. They include datasets on production, trade and consumption. Data can be extracted and aggregated according to different level of details and international standard classifications. It consists of a main application and several workspaces that include the datasets.

List of data available within FishStatJ

FishStatJ key features

- datasets browsing, data mining and reporting
- data querying, filtering, grouping and aggregation

Installating FishStatJ v4.01.0

Download FishStatJ
  - for Windows64-bit (7,8,10) auto-extract (Instructions)
  - for macOS

2.1.1. Windows requirements

FishStatJ is compatible with Windows 10; 64-bit version; cannot work with Windows 32-bit. The troubleshooting section below describes how to check your version of Windows.

Starting with FishStatJ version 4.01 Java 11 (OpenJDK project) is included with FishStatJ.

The FishStatJ needs about 1.5GB of disk space (400MB for the application, and the rest for data).

FishStatJ requires between 1Gb and 4GB of memory, depending on the size of the dataset used.

2.1.2. 32bit Windows installer

Starting with version 4.01.0 (as of March 2021) 32-bit Windows Operating system is not supported any more.
2.1.3. Using Windows auto-extract installer

When running the auto-extract installer (FishStatJ_Installer.exe), it will ask for the following permission:

After clicking on the Yes button, the installer will extract the application to C:\FishStatJ, and immediately launch FishStatJ after the extraction is complete.

No further action is required.

**Note:** The FishStatJ_Installer.exe file is not a real installer but a 7-Zip auto extract archive. As such, it does not require administrative permissions. It requires permissions to create the FishStatJ folder on the C:\ disk; this permission is usually available using accounts that lack Administrative rights.

2.1.4. Do not move or rename files

Please do not move or rename the files and folders, this will break the program. To resolve a corruption issue, delete the entire folder and its content: C:\FishStatJ and run the Install.exe program again to extract the whole folder structure.
2.1.5. Adding FishStatJ to the Taskbar

Applications can be added to the Taskbar (usually on the bottom of the screen) by right-clicking on the FishStatJ.exe file and select the Pin to Taskbar option.

A FishStatJ shortcut has now been added to the Taskbar:
2.2. Windows troubleshooting

2.2.1. Installation issues
FishStatJ is a 64-bit software, and therefore requires Windows 10, 64-bit. In the case the FishStatJ application does not start (show the FishStatJ logo, then the main menu); perform the following steps to delete and re-copy the application:

- Before launching the EXE Auto-Extract to install a new version, exit any open instance of FishStatJ (File → Exit) so that the files of the new version can be copied.
- Delete the FishStatJ folder inside the C:\ disk. using Windows explorer.
- Re-run the FishStatJ auto-extract EXE

2.2.2. How to check if your computer supports 64-bit
FishStatJ is a 64-bit software, and therefore requires 64-bit Windows. The reason for this 64-bit requirement relates to the memory handling required for loading statistical data.

To check if your computer is running Windows 64-bit, please refer to the following Microsoft Support webpage: support.microsoft.com/en-us/help/13443/windows-which-operating-system

System type shows whether your computer is running a 32- or 64-bit version of Windows.
2.2.3. Diagnostic reporting

In case you encounter an issue with the application, please turn on Log diagnostic reporting, which you can find in the Edit → Preferences menu and then exit and re-launch FishStatJ.

When you turn on Log diagnostic reporting in the Preferences, FishStatJ will check and create a log report if the program encountered an error. Please do share this report with us – it helps us to diagnose problems.

We are working constantly to update our data; publishing workspaces with the latest fisheries and aquaculture data. We are grateful for any type of feedback, since it allows us to improve the application.
2.3. Installing on macOS

To download the FishStatJ for macOS, please go to fao.org/fishery/statistics/software/fishstatj/en.

2.3.1. macOS requirements

FishStatJ is compatible with macOS 10.13 (HighSierra) or later.

Starting with FishStatJ version 4.01 Java 11 (OpenJDK project) is included with FishStatJ.

The FishStatJ needs about 1.5GB of disk space (500MB for the application, and the rest for data).

FishStatJ requires between 1Gb and 4GB of memory, depending on the size of the dataset used.

2.3.2. Installation

After the FishStatJ application is extracted from the ZIP file, it can be launched directly run from the Desktop, or moved to the Applications folder.

The FishStatJ application is code-signed and starting with version 4.01 is also notarized with Apple. As it is not an application from the app store: at the first launch it requires the actions below in order to obtain permission to run.
2.3.3. Authorization

In order to authorize FishStatJ, security settings need to be adjusted in System Preferences → Security & Privacy; to change settings the Preferences Panel must be unlocked first.


The next step is to download workspaces, for this please refer to section 3.1.1.
2.4. macOS troubleshooting

2.4.1. Diagnostic reporting

In case you encounter an issue with the application, please turn on Log diagnostic reporting, which you can find in the Edit → Preferences menu and then exit and re-launch FishStatJ.

When you turn on Log diagnostic reporting in the Preferences, FishStatJ will check and create a log report if the program encountered an error. Please do share this report with us – it helps us to diagnose problems.

We are working constantly to update our data; publishing workspaces with the latest fisheries and aquaculture data. We are grateful for any type of feedback, since it allows us to improve the application.
2.5. FishStatJ Privacy Policy

FishStatJ does not process or store any user input, and does not collect any user related information.

FishStatJ downloads a small file at startup, this requires an internet connection:
- in order to inform the user about program updates
- in order to present the user with a list of workspaces available for download
This is described in detail in section 12.6 (update notification).

The internet connection is used to download workspaces (statistical data), as described in section 3.1 (manage workspaces). The download of workspaces is entirely under the control of the program user.

The location of the data is described in detail in section 12.4 (workspace folder).

The workspace folder contains the application log. The log contains information about the internal state of the program - no user information. The log can be viewed by the user as described in section 2.2.4 (diagnostic reporting); section 12.4 (metadata folder).

FishStatJ does save the program settings modified by the user. The settings are managed using preferences as described in section 5.4 (Preferences).
2.6. Workspaces (statistical data)

Workspace files carry the statistical data. You can install an unlimited number of workspaces on a computer. However, FishStatJ can only work with one workspace at a time.

A workspace can contain one or more datasets. For the dissemination of data, workspaces are compressed into workspace files (.wks extension). FishStatJ downloads and extracts/installs workspaces automatically.

We currently offers several different workspaces files, which contain the following datasets:

- the **Global Production** workspace which contains:
  - Global Production
  - Capture Production
  - Aquaculture Production

- the **Regional workspace** with contains:
  - CECAF (Eastern Central Atlantic)
  - GFCM (Mediterranean and Black Sea)
  - RECOFI capture production
  - SEATL Southeast Atlantic Capture Production

- the **Food Balance** workspace which contains:
  - Food Balance Sheet
  - Population data

- the **Commodities** workspace which contains:
  - Fisheries Commodities Production and Trade

Please refer to section 3.1 (manage workspaces) for loading data into FishStatJ.
3. File Menu

3.1. Manage workspaces

The **Manage workspaces** menu allows the user to manage the workspaces:

- Open workspaces already installed.
- Download and install workspaces (from the FAO website).
- Delete workspaces installed on the computer.

When you click on **Manage workspaces**, the **Workspaces Manager** window appears on the screen. There, two kinds of workspaces are displayed:

- Workspaces in **red color** are not installed on the computer (also if there is a new version available).
- Workspaces in **blue color** are installed on the computer.

The screenshot below shows that version 2018.1.0 of the “FAO Global Fishery and Aquaculture Commodities Statistics” workspace is installed on the computer:
Workspaces already installed on the local disk can be **Opened** for viewing the data, or **Deleted** from the computer.

Manually downloaded workspaces can be imported using the **Import** button. Workspaces that are already installed are not shown as available for download.
3.1.1. Installing a new workspace (download)

To install a new workspace, select an uninstalled (in red) workspace and click on the Download… button.
Clicking on the **Download** button will open a new window, the workspace import wizard:

A progress bar appears during the download:
Once the file has finished downloading, press the **Next** button to install it on your computer.

![FishStatJ new workspace import](image)

- **File selected**: C:\Users\[username]\Downloads\FAO_FI_FBS_2017.1.0.fws
- **Workspace metadata**
  - **Acronym**: FAO_FI_FBS
  - **Version**: 2017.1.0
  - **Name**: FAO Food balance sheets of fish and fishery products
  - **Description**: FAO Food balance sheets of fish and fishery products
  - **Provider**: Food and Agriculture Organization of the United Nations
  - **Location**: C:\Users\[username]\Downloads
If an older version of the data is present (this typically happens after the yearly release of updated workspaces from FAO), FishStatJ will ask if the new version should overwrite the old version – or keep both (resulting in two versions of the same data installed). Select the option most appropriate for you, and click Next.

Please wait while the workspace is installing.
When the installation is complete, click the **Finish** button.

After clicking on **Finish**, the **Dataset browser** window appears. To start using your newly installed workspace, please refer to section 3.2 (open dataset) below.
3.1.2. Deleting a workspace

In the Workspaces manager, selecting a workspace will show metadata for this particular workspace (Acronym, Version, Name, Description, Provider, and Location on disk). The selected workspace is permanently removed from your computer when you click on the Delete button.

3.1.3. Importing a workspace

The Import... button allows the user to import manually downloaded workspaces into FishStatJ. However, since FishStatJ is able to download workspaces files, most users do not need to download and import workspaces manually.
If you need to import a workspace manually, click on the **Import...** button of the **Workspaces Manager**.

A file explorer window will appear, inviting you to select the `.fws` file corresponding to the workspace you wish to import. Select the `.fws` file and click on the **Open** button.
In the window that appears, click on the **Next >** button.

The following window is displayed, confirming that you have selected a valid workspace file and inviting you to install it on your computer. To do so, click on the **Next >** button.
Once FishStatJ confirms that the workspace installation is complete, click on the **Finish** button to go back to the interface and open the workspace.
3.2. Open Dataset...

**Note:** This option is only available when a workspace is currently open in FishStatJ.

Selecting this option will present the **Dataset browser** window, where datasets may be opened and brought into FishStatJ for viewing.

Once you have opened a dataset, the **Manage workspaces** item under the **File** menu is disabled (or dimmed); until you close the active workspace by clicking on the **Close workspace** item.

Selecting a dataset by clicking on the items listed on the left-side of the window will present the associated metadata on the right-side of the window. Select a dataset and click on the **OK** button to open the dataset content.
3.3. Close workspace

Selecting this item will close the current workspace and all datasets and that are active within this workspace.

**Note:** The Close workspace option saves settings for all active datasets. Next time you launch FishStatJ, saved settings are applied. If you do not want a dataset to open automatically next time you open FishStatJ, just close it using the Close icon on the dataset panel:

**Note:** Filtering and aggregation settings are also recorded for each dataset; and automatically re-applied when you launch FishStatJ next time.

If the **Save working session on exit** option (located in Edit → Preferences) is active, when FishStatJ restarts the datasets that were open when the user exited the application will automatically reopen.
3.4. Export selection (CSV file)...

Selecting this option will save all selected rows into a comma-separated values (CSV) file:

A Save As pop-up window will appear so that all selected rows may be saved into a .csv file on a given location of the hard drive.

When the save of the selected records into a .csv file is complete, a confirmation message will appear:
Settings for export of CSV files are managed in **Edit → Preferences → Data Export**. See section 5.4(data export) for more information.

### 3.5. Exit

Selecting this option will close the FishStatJ program.
4. Data display

4.1. Displaying a dataset

When a dataset is open, the main window of FishStatJ looks like this:
4.2. Notes (if applicable)

Country notes are now made visible in the data display through a red triangle. In the past notes have been published in the annual statistical yearbook (PDF version).

The red triangle only shows, if the object has note text defined.

<table>
<thead>
<tr>
<th>Country (Name)</th>
<th>Continent (Name)</th>
<th>ASFIS species (Name)</th>
<th>FAO major fishing area</th>
<th>Environment (Narr)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Afghanistan</td>
<td>Asia</td>
<td>Cyprinids nei</td>
<td>Asia - Inland waters</td>
<td>Freshwater</td>
</tr>
<tr>
<td>Afghanistan</td>
<td>Asia</td>
<td>Rainbow trout</td>
<td>Asia - Inland waters</td>
<td>Freshwater</td>
</tr>
<tr>
<td>Albania</td>
<td>Europe</td>
<td>Bighead carp</td>
<td>Europe - Inland waters</td>
<td>Freshwater</td>
</tr>
<tr>
<td>Albania</td>
<td>Europe</td>
<td>Common carp</td>
<td>Europe - Inland waters</td>
<td>Freshwater</td>
</tr>
<tr>
<td>Albania</td>
<td>Europe</td>
<td>Crucian carp</td>
<td>Europe - Inland waters</td>
<td>Freshwater</td>
</tr>
<tr>
<td>Algeria</td>
<td>Africa</td>
<td>Barbel</td>
<td>Africa - Inland waters</td>
<td>Freshwater</td>
</tr>
<tr>
<td>Algeria</td>
<td>Africa</td>
<td>Bleak</td>
<td>Africa - Inland waters</td>
<td>Freshwater</td>
</tr>
<tr>
<td>Algeria</td>
<td>Africa</td>
<td>Caramote prawn</td>
<td>Mediterranean and...</td>
<td>Brackishwater</td>
</tr>
<tr>
<td>Algeria</td>
<td>Africa</td>
<td>Common sole</td>
<td>Mediterranean and...</td>
<td>Brackishwater</td>
</tr>
</tbody>
</table>

The notes are visible by selecting a row, and then right-clicking on the Country:

- Chinese 2000-2002 aquaculture production data for “Oriental river prawn” (Macrobachium nipponense) have been included based on published reports. The figures for 2003-2008 have been provided by the national reporting office.

For statistical purposes, the data for China do not include Hong Kong Special Administrative Region (Hong Kong SAR), Macao Special Administrative Region (Macao SAR) and Taiwan Province of China.

Data for “Turbot” for 2003-2017 were subtracted from “Lefteye flounders nei” as FAO estimates.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
<td>Country name</td>
</tr>
<tr>
<td>ISO3 code</td>
<td>CHN</td>
<td>ISO3 code</td>
</tr>
<tr>
<td>ISO2 code</td>
<td>CN</td>
<td>ISO2 code</td>
</tr>
<tr>
<td>Internal identifier</td>
<td>41</td>
<td>Internal Identifier</td>
</tr>
<tr>
<td>Official name</td>
<td></td>
<td>Official name</td>
</tr>
<tr>
<td>Code UN (M49)</td>
<td>156</td>
<td>Code UN (M49)</td>
</tr>
<tr>
<td>FAO 12 characters</td>
<td>China</td>
<td>FAO 12 characters code</td>
</tr>
</tbody>
</table>

The note text can be exported using copy/paste.
4.3. Toolbar icons

The toolbar icons on the left side provide quick access to the data tools. These are also exposed in the Data menu, where you also find a detailed explanation.

The toolbar icons on the right side provide quick access to the dataset attachments. These are also exposed in the Metadata menu, where you also find a detailed explanation.

4.4. Row Details

Selecting/highlighting a row (as shown above) will present the yearly data values on the lower part of the window (as shown under the Row Details tab).

4.5. Number of rows

The number of rows on display is shown in the lower-right part of the window. This number depends on the filtering criteria chosen by the user; Filtering is explained in section 6.1 (Filter).

4.6. Memory Status

The memory bar shows the state of the Java heap memory, which is a feature of RCP applications. This feature is useful for troubleshooting only.
5. Edit Menu

5.1. Select all

Clicking on this option will select all the rows in the currently open dataset:

![Screenshot of the Edit Menu showing the Select all option and how it selects all rows in the currently open dataset.](image1.png)
5.2. Select none

Clicking on this option will deselect any selected row in the currently open dataset:
5.3. Copy selection

Selecting this option will copy all selected rows into the clipboard. When the copy of the selected records into the clipboard is complete, a confirmation message will appear:

This option is useful if you intend to copy the selected rows directly into an opened spreadsheet.

The settings related to how data is copied to the clipboard are managed in Edit → Preferences → Data Export. See section 5.4 (data export) for more information.
5.4. Preferences

FishStatJ’s Preferences include a range of settings that can be modified by the user. They can be accessed (i) from the Edit menu…

… and (ii) from the toolbar by clicking on the Preferences icon.

The Preferences window is presented below. Preferences are grouped in five categories, which are listed on the left side of the window. Specific options for each Preferences category are listed on the right side of the window.
5.4.1. General preferences

The General preferences options are the following:

- **Save/Load timeseries settings on exit/open** controls if the time series settings (like filtering, aggregation, column settings) are automatically saved (when exiting FishStatJ) and loaded (when launching the application).

- **Synchronize timeseries within the same dataset**: This is useful for Aquaculture data, to keep the time series of Quantity and Value in sync. Any filtering/aggregation settings will be applied to both time series.

- **If Log diagnostic reporting** is enabled, FishStatJ will read the log-file and check for any errors every time the application starts. In case the logs contain any program errors, it copies the last two months of logs into a file called mail.txt and ask the user to send this file to us for analysis. If the Outlook software on Windows is installed, FishStatJ automatically prepares the e-mail message. This option is disabled by default.

  **Note**: FishStatJ does not automatically submit any log information. You can check the content of the text file before sending, and you have to (manually) send the file to FAO (refer to section 12.4.2).

  In case of problems, the log analysis is useful to understand the cause of the problem. This helps us to fix the problem for the user reporting the problem—and to improve the quality for all users.

- **Workspace download location** allows to set the location where FishStatJ downloads workspaces before they are installed. We added this setting because some users reported that the Downloads folder does not exist on their PC.

  Refer to section 12.4 for details on the log location, and FishStatJ workspaces.
5.4.2. Data display

The **Data display** preferences allows the user to specify:
- If the dataset panel automatically centers on the last column of the data each time it a dataset is loaded (set by default).
- Whether the width of the columns that contain values is automatically adjusted, or a fixed width (as determined by the user).
- If the dimension column header shows the attribute name (the default), or a generic dimension name.

**Note:** If the column width display is set too small so that the observations are not readable, an easy solution is to set a column width of 60.
5.4.3. Data display – Number formatting

Number formatting options control how values are shown (i.e. set the number of digits before and after decimals; use point or comma as decimal separator; use decimal or scientific notation). It is important to note that these formatting preferences are used for display and when exporting data.
5.4.4 Data display – Symbols and Colors

Symbols and Colors options control how data symbols are shown (set color and symbol display). It is important to note that these formatting preferences are used for display and when exporting data.
5.4.5. Data export

This menu includes several options that set the modalities of data exports.

- **Export tables headers**: when selected, headers are exported.
- **Split values and symbols in two columns**. This is to avoid issues when analyzing the data after exporting it. Indeed, mixing symbols and figures within the same cells in a spreadsheet can make data analysis impossible, notably because the spreadsheet software will not recognize cells as numbers if these contain non-numerical characters.
- **Export selection criteria**: will add the filtering/aggregation settings to the export.
- **Don’t export symbols**. This is to avoid issues when analyzing the data after exporting it. Indeed, mixing symbols and figures within the same cells in a spreadsheet can make data analysis impossible, notably because the spreadsheet software will not recognize cells as numbers if these contain non-numerical characters.
- **Export with totals on selected rows**.
- **Export citation**. See section 9.3.
- **Re-adjust the preferences on each export**: selecting this will show a dialog window before each export operation, to make sure that the proper export settings are selected before each data export.
5.4.6. Internet Access
The preferences regulating Internet access by FishStatJ are listed below:

- The **Settings for version download** are described in detail in section 12.6 (update notification).

- **Use Proxy** is provided in case the network is protected with a proxy server. It allows FishStatJ to download the current information (program version and workspaces versions) and download workspaces (data) using a proxy server. We added proxy settings as requested by some users.

  The use of proxy is controlled with the **use Proxy** checkbox. Proxy server IP address and port number fields are required (must be filled) if proxy is activated.

  The Proxy user ID and Proxy Password fields can be left empty.
5.4.7. Languages

The language menu allows the user to change the language in which FishStatJ is displayed.

A familiar popup window will appear if the user tries to change the language. Click on the Yes button to restart the application.
6. Data Menu

6.1. Filter...

The timeseries filter becomes enabled once a dataset is open. Filter can be accessed (i) from the Data menu...

... and (ii) from the toolbar by clicking on the Filter icon.
Selecting **Filter** will open the **Time series filtering** window:

On the left side the items are *included* on the dataset panel, on the left side the items are *excluded* from the dataset panel. The **Include** side is empty by default, meaning that all items are shown.

Items available for filtering depend on the dimensions of the dataset loaded. In the example above, available filters are Country, Species and Fishing area. Australia is the only country selected in this example.

The arrow buttons copy the selected items from left-to-right or from right-to-left, according to the direction of the buttons:
The double-arrows copy all items in the direction indicated:

Clicking OK will activate the filter and refresh the data display in the main window. Right-clicking on an item will display a quick selections menu:

- **Select all**
- **Deselect all**
- **Invert selection**
- **Choose attribute** allows to select the attribute used for the Filter dialog. This setting is remembered by FishStatJ:

![Screenshot of filter options]

- **Details on [name of item]** shows details on the selected item:

![Screenshot of item details]
6.1.1. Selection mode preferences

The Time series filtering window includes a button to open the Selection mode preferences:
It will bring up the Selection Preferences window:

A Dimension value filter can be defined for each of the Dimensions. The filter controls the list of items shown in the Time series filtering window.

All will show all items included in that particular workspace.

Only those referenced will show only reference objects which appear in the timeseries.

Note: to apply new settings, a restart of FishStatJ is required.
6.2. Aggregate

The Aggregate function is available once a dataset is open. It can be accessed (i) from the Data menu…

…and (ii) from the Aggregate icon in the dataset toolbar:
FishStatJ memorizes aggregation settings for each dataset. On the **Time series aggregation** popup window, three modes of aggregation are available for each data dimension:

- When **Detailed** is selected, the dimension is effectively not aggregated.
- When the user selects **Grouped**, the aggregation can be made on the basis of each individual group associated with the dimension. Groups can also be **Handpicked**.
- When **Aggregated** is selected, all the data associated to a given dimension is aggregated.
As an example, grouping the Country dimension by Continent while aggregating Species and Fishing area, produces the following result:

<table>
<thead>
<tr>
<th>Country (Continent)</th>
<th>Species (ASFIS spec...)</th>
<th>Fishing area (FAO ...)</th>
<th>Unit (Unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Africa</td>
<td>All</td>
<td>All</td>
<td>Tones</td>
</tr>
<tr>
<td>Americas</td>
<td>All</td>
<td>All</td>
<td>Tones</td>
</tr>
<tr>
<td>Asia</td>
<td>All</td>
<td>All</td>
<td>Tones</td>
</tr>
<tr>
<td>Europe</td>
<td>All</td>
<td>All</td>
<td>Tones</td>
</tr>
<tr>
<td>Oceania</td>
<td>All</td>
<td>All</td>
<td>Tones</td>
</tr>
<tr>
<td>Others</td>
<td>All</td>
<td>All</td>
<td>Tones</td>
</tr>
</tbody>
</table>
6.3. Columns...

This function allows the user to change the columns (attributes) that are used to view the dataset. A Preferences panel is used, because the settings are remembered.

The Columns function can be accessed (i) from the Data menu…

… and (ii) from the toolbar by clicking on the Columns icon.
For each dimension, columns can be added, modified and removed by clicking on the **New…**, **Edit…** and **Remove…** buttons, respectively.

**Note:** For species, when the common name is not available, the scientific name will be shown instead.

**Note:** When a dimension is aggregated, all attributes in that dimension are changed for the duration of the aggregation setting to show the aggregation group.

For example if you configure to display Country(Name) and Country(ISO3-Code) and then aggregate by Continent, both columns show Continent(Name) for as long as the aggregation is active.
When creating a new column or modifying an existing one, the Concept used to display a given Dimension can be changed by selecting **Concept**:

![Dimension column settings](image)

For each Concept, the **Attribute** can be selected:

![Dimension column settings](image)

Example: for the **Species** dimension, the common names used to display species can be replaced with the corresponding scientific names by selecting the **Scientific name** attribute.

**Periods** are the years on display, which may be changed, as shown below:
6.4. Sort...

The Sort function can be accessed (i) from the Data menu…

… and (ii) from the toolbar by clicking on the Sort icon.
The **Sort** window allows to choose how to sort the data. Sorting can be different from the columns shown on the display: for example it is possible to display the Species dimension by ISSCAP group, but sort it by Commodity. The sort ordering (i.e. ascending or descending) is selected using the **Direction** options on the right end of the window.

When using multiple sorting criteria, higher priority will be given to the criteria that are positioned higher in the list order.
6.5. Top/Other...

The Top/Other function can be accessed (i) from the Data menu...

... and (ii) from the toolbar by clicking on the Top/Other icon.
The **Top/Other** menu allows selecting records by the following criteria:

- **Top** [number] of records;
- **Top** [percentage] of records; or
- **records greater than** [cut-off value].

You can enter selection value (number of records/percent of records/value greater). All records that do not meet the criteria are aggregated into others, this is why the function is called Top/Other.
As an example, selecting the top 10 records for the year 1975 is shown below.
6.6. Custom groups

The Custom groups function allows the user to define specific groups of countries, species, fishing areas, and measures. Typically, such groups are created by users to avoid repeated filtering for groups that are part of common workflows.

Custom groups can be accessed (i) from the Data menu...

… and (ii) from the toolbar by clicking on the Custom groups icon.

Note: The Custom groups menu item is only available when a dataset is open.

A number of custom groups are predefined for some time series elements. The above screen shows the custom groups for the Country dimension, while the image below shows custom groups that already defined for the Species dimension.
When a new custom group is to be created with the **New...** button, the **New custom group definition** window appears on the screen.
When an existing custom group requires editing with the **Edit...** button, the **New custom group definition** popup is presented with the existing group members listed in the **Include** field.

A **Custom group name** and **Custom group description** can be entered in the lower part of the window. As a minimum the English field should be filled.
6.7. Calculated columns...

The **Calculated columns** function allows the user to create additional columns that are built from the original dataset columns.

**Calculated columns** can be accessed (i) from the Data menu...

![Data menu](image1)

... and (ii) from the toolbar by clicking on the **Calculated columns icon**.

![Calculated columns icon](image2)
When this function is accessed, a **Calculated columns Preferences** window appears, where the user can create or edit calculated columns is displayed as shown below:
Calculated columns may be created (New...) or edited (Edit...) by clicking on the corresponding buttons. This opens the Calculated columns definition popup window.
Many statistical functions are available for calculated columns, as shown below:
When a calculated column is created, it is shown on the right side of the dataset panel:

![Image of dataset panel with calculated column]
7. Format Menu

7.1. Column width

Selecting Column width will take the user to the Data display tab of the Preferences window. See section 5.4.2 for more information.

7.2. Number formatting

Selecting Number formatting will take the user to the Data display tab of the Preferences window. See section 5.4.3 for more information.

7.3. Symbols and Colors

Selecting Symbols and Colors will take the user to the Data display tab of the Preferences window. See section 5.4.4 for more information.
8. View Menu

The View menu is only enabled when a dataset is open, otherwise it is dimmed (not available).

8.1. Show details

Selecting or deselecting this option will turn on or off the detailed information that is displayed at the bottom of the FishStatJ main display.

The Show details option can be toggled on and off (i) from the View menu…

… and (ii) from the toolbar by clicking on the Show details icon.
Turning on this option will reduce the number of time series records on display. On the image below, the **Row Details** tab is turned on.
Deselecting this option will remove the 'details' shown at the bottom of the FishStatJ main display. In the image below, the details are not displayed:

<table>
<thead>
<tr>
<th>Country</th>
<th>Species (ASRIS spec)</th>
<th>Fishing area (FAO)</th>
<th>1950</th>
<th>1951</th>
<th>1952</th>
<th>1953</th>
</tr>
</thead>
<tbody>
<tr>
<td>Albania</td>
<td>Blue and red shrimp</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Blue whiting=Po...</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Bluefish</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Bogue</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Carmote prawn</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Catcharks, nurveh...</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Common carp</td>
<td>Europe - Inland w</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Common cuttlefish</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Common doce</td>
<td>Europe - Inland w</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Albania</td>
<td>Common dentex</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Common octopus</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Common sole</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Common spiny lo...</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Common squids ...</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Croakes, drums rei...</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Crucian carp</td>
<td>Europe - Inland w</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>Albania</td>
<td>Pectoral cuttleflh</td>
<td>Mediterranean</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

21249 filtered rows: 379M of 1005M
8.2. Grand totals

Activating **Grand totals** will create one or two (depending on the dataset) additional tabs in the FishStatJ display that show grand totals for the time-series.

The **Grand totals** option can be toggled on and off (i) from the **View** menu…

… and (ii) from the toolbar by clicking on the **Grand totals icon**.
The new tab(s) will be opened at the bottom of the window, as shown on the image below:

For example, the **Global production by production source - Quantity** dataset (shows above) has two Grand total tabs (**Number** and **Tonnes**) because two types of units can be used to display the data.

**Note:** When selecting a grouped aggregation (refer to section 6.2) which has overlapping group members the total shown is not the sum of the data on display, but the sum of the underlying raw data. Overlapping means, that a dimension (for example country) of a statistical observation is present in more than one group. In this case, the observations (for example catch) of this country are counted for each of the groups of which the country is a member; but are only counted once for the total.

Examples of overlapping groups are economic groups or RFB (ac country can be member of several regional fishery bodies).
9. Metadata Menu

The **Show notes...**, **Show citation...** and **Show map...** items are enabled depending on the attachments that are available for the current dataset.

9.1. Show metadata...

Selecting this option will display the metadata about the time-series that is selected within FishStatJ.

Metadata can be accessed (i) from the **Metadata** menu...

![Metadata menu](image)

... and (ii) from the toolbar by clicking on the **Metadata icon**.

![Metadata icon](image)
An example of the window showing metadata is shown below:
9.2. Show notes…

Selecting this option will display the notes attached to a dataset. Notes contain descriptions about the time-series that is selected within FishStatJ.

Notes can be accessed (i) from the Metadata menu…

… and (ii) from the toolbar by clicking on the Notes icon.

Note: The Show notes menu item is enabled and the Notes icon is shown when the current dataset has notes embedded.
An example of the **Notes window** is displayed below:

![Notes window example](image)

**GLOBAL FISHERY PRODUCTION**

The annual series of total fishery production began in 1950. Data relate to nominal catch of fish, crustaceans and molluscs, the production of other aquatic animals, plants and catches of aquatic mammals, taken for commercial, industrial, recreational and subsistence purposes from inland, brackish and marine waters. The harvest from mariculture, aquaculture and other kinds of fish farming is also included.

Data include all quantities caught and landed for both food and feed purposes but exclude discards. Catches of fish, crustaceans and molluscs are expressed in live weight, that is the nominal weight of the aquatic organisms at the time of capture. The harvest of aquatic plants is given in wet weight. Data are given in tonnes (=1000 kg), except those for whales, seals and crocodiles, which are given in numbers.

To assign nationality to catches, the flag of the fishing vessel is used, unless the wording of chartering and joint operation contracts indicates otherwise.

Fish, crustaceans, molluscs and all other aquatic organisms included in the database have been classified according to approximately 2309 commercial species items, further arranged within the 50 groups of species constituting the nine divisions of the FAO International Standard Statistical Classification of Aquatic Animals and Plants (ISSCAAP). Starting with the March 2002 release, data included in this dataset reflect a revision of the ISSCAAP groups. This revision affected names and species attribution of groups 33, 34 and 37 of the Marine Fishes division. The taxonomic code descriptors are taken from the "ASFIS list of species for fishery statistics purposes".

According to the inland or marine area where caught, capture production is also classified into eight major inland fishing areas and 19 major marine fishing areas, internationally established for fishery statistical purposes.
9.3. Show citation…

Selecting this option will display the dataset citation, allowing to copy/paste it for easy reference.

The dataset citation can be accessed (i) from the Metadata menu…

… and (ii) from the toolbar by clicking on the Citation icon.

Note: The Show citation menu item is enabled and the Citation icon is shown when the current dataset has a citation embedded.
An example of the **Citation window** is displayed below:
9.4. **Show map…**

Selecting this option will display the map attached to a dataset. Those maps usually represent FAO’s fishing areas.

The Map can be accessed (i) from the **Metadata** menu…

![Metadata menu](image)

… and (ii) from the toolbar by clicking on the **Map icon**.

![Map icon](image)

**Note:** The **Show map** menu item is enabled and the **Map icon** is shown when the current dataset has a map embedded.
An example of the **Map window** is displayed below:
10. Help Menu

The Help menu is shown below. It gives access to additional tools, preferences and help related to the FishStatJ software.

10.1. Getting Started

The Getting Started item from the Help menu automatically downloads the Getting Started with FishStatJ manual and opens it. The manual is a portable document format (PDF) file.

- Windows requires Acrobat Reader to open PDF documents
- macOS can open PDF documents using the Preview application

Note: When working with unreliable internet access, we suggest to open the manual when an internet connection is available, as this will make it available in case of future connection interruptions.

10.2. User Manual

The User Manual item from the Help menu automatically downloads the FishStatJ manual and opens it. The manual is a portable document format (PDF) file.

- Windows requires Acrobat Reader to open PDF documents
- macOS can open PDF documents using the Preview application
When working with unreliable internet access, we suggest opening the manual when an internet connection is available, as this will make it available in case of future connection interruptions.

10.3. About FishStatJ

This item presents FishStatJ information about the program version, legal use, and contacts for assistance. The About FishStatJ window is shown below:

- **FishStatJ, a tool for fishery statistics analysis**
- **Release:** 3.05.0-β15
- Developed by Thomas Berger, Fabrizio Sibeni, and Francesco Calderini
- This product includes software developed and distributed under the EPL, LGPL, and Apache licenses.
- Please also refer to the Dataset Notes (Menu | Metadata | Show Notes)
- Questions and feedback should be addressed to:
  - FAO
  - Fishery and Aquaculture Department
  - Statistics and Information Branch
  - Email: Fish-Statistics-Inquiries@fao.org
11. Frequently asked questions (FAQ)

11.1. How to export data?
You can export data from FishStatJ in two different ways (for more information, refer to section 5.4):

- You can simply copy a selection of rows and paste it on an Excel file (with the right button menu or with the **CTRL + C** shortcut).
- Or you can go to **File → Export selection (CSV file)**...

You can configure how data and symbols are exported (or not exported) in **Edit → Preferences → Data export** (refer to section 5.4.5)

11.2. What does that symbol mean?
FishStatJ uses the following symbols for statistical data:

... Data not available; unobtainable; Data not separately available but included in another category

- Nil or zero

0 More than zero but less than half the unit used

F FAO estimate from available sources of information

nei Not elsewhere included

In FishStatJ, you can configure the color of the symbols in the panel:
**Edit → Preferences → Data Display → Symbols and Colors** (refer to section 4.4.4).

As for data and symbol export to Excel, please be informed that you can configure how data and symbols are exported (or not exported) in:
**Edit → Preferences → Data export.**
**Don’t export symbols** is one of the options you can select (refer to section 5.4.5).

11.3. Why am I getting different numbers than those from the FAO Yearbook of Fishery and Aquaculture Statistics/SOFIA?
Trying to cover all products derived from fisheries activities, in both inland and marine waters, the FAO Fishery production datasets (capture and aquaculture), include some products which are not (or not directly) destined to food consumption, such as marine mammals, crocodiles, corals, pearls, mother-of-pearl, sponges and aquatic plants. Those products are excluded from the all country, regional and world...
totals presented in FAO Yearbooks of Fishery Statistics as well as other FAO publications.

When viewing time-series data in FishStatJ, in order to obtain the same aggregates you must first filter the dataset using a Custom Group:
1. Open the Time series filtering window (Data → Filter or F4)
2. Click the ASFIS Species tab
3. Click the Species selection groups of Yearbook/SOFIA group
4. Click Fish, crustaceans, molluscs...
5. Click the single left arrow in order to move all selected species belonging to Fish, crustaceans, molluscs, etc. under the Include panel on the left.
6. Click on the OK button. The program will return you to FishStatJ's main window.

The aggregation grouping for capture and aquaculture datasets is mentioned in the dataset notes where applicable. Access to dataset notes is explained in section 9.2.

11.4. CFishStatJ offline? n I use FishStatJ offline?

When the download of the auto-update information fails, FishStatJ produces the following warning:

If there is no internet connection possible, FishStatJ will run but the following functions will not be available:

* The notification of a new program version is not available (Refer to section 11.6 for a detailed description of the auto-update notification, and a description of data download from the internet).
* No workspaces are shown for automatic download: the Manage workspaces dialog only shows workspaces already downloaded/installed (refer to section 3.1)
* Download of the user manual is not possible (refer to section 10.2)

Section 5.4.6 explains Internet access proxy configuration.
11.5. Some historical data figures have changed. Why?
Refer to section 12.3 for a discussion on data revisions.

11.6. Where to find detailed notes for each dataset?
Additional information about the statistics presented in each dataset collection are available in the General notes, accessible in Metadata → Show metadata → Attachments (or by clicking on top right button of data panel).
Refer to section 9.2 and 9.3 for viewing dataset notes and data citation.

11.7. How often is the data/application updated?
We publish new data as soon as we receive the complete set from member countries and have completed our verification. Usually, datasets are updated once per year. The release time for Global Capture and Aquaculture Production is in the second quarter every year.

New or updated datasets will automatically show in the Manage workspaces menu; refer to section 3.1 for a detailed explanation.

When the FishStatJ application is launched, it will also check for updates – and inform you if there is a new version available for download; refer to section 11.6 for the auto-update notification.

Data update/revisions are explained in section 12.3; internet access is discussed in section 5.4.6.
11.8. FishStatJ is being flagged as a virus threat

We have received various reports indicating that the FishStatJ software has been falsely identified as being a virus threat. Indeed, we work hard for FishStatJ to be the best product possible, and we would not knowingly distribute an infected version.

Wikipedia defines a false-positive as a false alarm: wikipedia.org/wiki/False_positives_and_false_negatives.

If you receive such alert from your antivirus software, we suggest the following actions, in the following order:

- Please send us an e-mail (Fish-Statistics-Inquiries@fao.org), describing the antivirus software used, and the alert message received (this way we can double-check your download, and also warn other users).
- Please inform you virus software vendor and notify them of the ‘false positive’ indication. The vendor can then quickly investigate (check our download) and release an update to their virus definitions (definitions are patterns to detect infected software).
- If you think FishStatJ is corrupted, the best is to re-download and expand a fresh copy.

NEVER consider deactivating your virus protection - that would be irresponsible in this digital age!

11.9. How does FAO assign nationality to catches?

As established by the United Nations Statistical Commission in 1954, catches are assigned to the country of the flag flown by the fishing vessel. The flag State is also responsible for the provision of the relevant data to FAO and other organizations such as Regional Fishery Bodies (RFBs).
12. More on FishStatJ

12.1. FishStatJ legal specifications

The FishStatJ software is provided free of charge to member countries of the Food and Agriculture Organization of the United Nations (FAO). It may be installed on personal or company computers without restriction or license. The statistics contained in this package may be used and published freely provided that the source is cited as FAO.

12.2. Bibliographic citation

FAO encourages the use, reproduction and dissemination of material in this information product. Except where otherwise indicated, material may be copied, downloaded and printed for private study, research and teaching purposes, or for use in non-commercial products or services, provided that appropriate acknowledgement of FAO as the source and copyright holder is given and that FAO’s endorsement of users’ views, products or services is not implied in any way.

All requests for translation and adaptation rights, and for resale and other commercial use rights should be made via fao.org/contact-us/licence-request or addressed to copyright@fao.org.

When quoting FishStatJ data, please use the reference that you can find in the General Notes attached to each dataset (Metadata → Show metadata → Attachments).

The citation for each dataset is available in the Metadata → Show citation menu. The bibliographic citation for FishStatJ is as following:


12.3. Data versioning and Data revisions

Where necessary, the data published in the previous releases of the dataset(s) of fishery and aquaculture statistics are revised.

Where figures in this release differ from those previously published, the amended data represent the most recent version. Some statistics provided to FAO by national offices, in particular those for most recent year, are provisional and may be amended in future editions.

An example of the version of FishStatJ is “2020.1.0”

Major version: is the year when the data was released (2017)
Minor version: is the release (1) and revision number (0)
Occasionally, we find errors, or we receive data from member countries after the release of the FishStatJ workspace. In these rare cases, we release a new revision of the data by increasing the revision number. This way, the new version is automatically visible in the **Workspaces Manager** as a new download. In this case, we would also include an explanation in the dataset notes. Refer to section 9.2 how to view dataset notes.

### 12.4. FishStatJ workspace folder

FishStatJ stores imported workspaces (and application files) in the user home directory:

- For Windows, use the **Windows + R** shortcut to open the Run command, enter `%USERPROFILE%\fishstatj_workspace` and click **OK**
- For macOS Finder enter `~/fishstatj_workspace` in **Go → Go to Folder** menu

The information inside workspace folder is described in detail below.

Refer to section 11.5 how to remove (un-install) FishStatJ.

#### 12.4.1. FishStatJ workspaces

Workspaces are stored in the FishStatJ workspace folder. They contain the time-series data, including the reference data (dimensions), and attachments (maps, dataset notes). There is one folder for each workspace installed.

Workspaces can be deleted permanently from disk, by opening the **Manage workspaces** menu and by using the **Delete** button.

#### 12.4.2. Workspace metadata folder

The FishStatJ application’s log and preferences are stored in the workspace folder, in a sub-folder called “.metadata”.

The FishStatJ application log is called “.log”.

FishStatJ application preferences are saved in this location: `.metadata/.plugins/org.eclipse.core.runtime/.settings`

**Note**: on macOS files and folders starting with a dot an invisible. To open the folder enter `~/fishstatj_workspace/.metadata` in **Go → Go to Folder** menu.

#### 12.4.3. Workspace manual folder

The FishStatJ manual is downloaded and opened from the manual folder inside the fishstatj_workspace. Refer to section 9.2 for more details on the manual.
12.5. Un-installing FishStatJ

FishStatJ can be un-installed by deleting the FishStatJ application folder (macOS: the application icon). The Windows application is usually located at: C:\FishStatJ. FishStatJ stores imported workspaces (data) in the user home directory; these can be deleted as well:

- For Windows enter `%USERPROFILE%\fishstatj_workspace` in the Run menu
- For macOS Finder enter `~/fishstatj_workspace` in Go → Go to Folder menu

FishStatJ is a cross-platform application and therefore does not use the Windows-registry, it stores all data and settings in the application and user home directory, as described above.

12.6. FishStatJ update notification

Starting with version 3.01 FishStatJ has automatic update capability built in. At program launch a very small XML file (~1KB) is downloaded from the FAO web-site. If the download of this file fails, FishStatJ will show a warning message (refer to section 10.6– No internet connection) and will continue to work with the data downloaded locally.

The URL download location of the XML file is shown in preferences, refer to section 4.4.6 - Internet Access.

The XML file enables the following 3 functions in FishStatJ, which are described below.

12.6.1. Automatic update notification

When we release a new version of FishStatJ, Windows users will see the following message at program startup; macOS users receive the program update notification shown in 11.6.2:

![New version FishStatJ]

There is a new FishStatJ v3.05.1 available. Download and Install?

[Start update] [Manual download] [Cancel]

Clicking the Start update button will start the download of the auto-extract file:
Once the download is complete, FishStatJ quits, and the extraction dialog appears:

Clicking the **Yes** button will expand the software, and launch the new version of FishStatJ.

If no internet connection is available at start-up, a message appears (section 10.6—No internet connection).

### 12.6.2. update notification

When we release a new version of FishStatJ, you will see the following message at program startup:

Clicking the **Yes** button will open the FAO FishStatJ web-page in a web browser. On this page, you find the latest FishStatJ application for download.

**Note:** The user has to perform the download of the application program, and install it on the PC. There is no auto-download or auto-update of the application.

If no internet connection is available at start-up, a message appears (section 10.6—No internet connection).
12.6.3. Workspace download
FishStatJ will show new or updated workspaces in the Manage workspaces dialog. Using this dialog, the user can choose which workspace to download and install on the PC.

For a description of the workspace management; please refer to section 3.1-Manage workspaces.

Refer to section 12.3 for an explanation of workspace/data versioning.

Available workspaces, their version and download location are contained in the XML file; if no internet connection is available then only workspaces downloaded and installed previously are shown.

12.6.4. FishStatJ manual download

The first time the user manual is opened, or when a new version is available, the PDF manual is downloaded. The version of the manual and download location of the manual is contained in the XML file.

Refer to section 10.2 (User Manual) for how to open the FishStatJ manual.

The FishStatJ manuals are downloaded to the workspace folder. Refer to section 12.4.3 (FishStatJ manual folder).

When running offline, the manual can only be opened if it was previously downloaded.
12.7. Assistance and Contact

On the FishStatJ web-page (fao.org/fishery/statistics/software/fishstatj/en) you can find

• New program versions for download
• A list of workspaces and their versions available for download using FishStatJ
• A quick-start guide for installing the program
• The download link to this manual
• The e-mail contact for support (fish-statistics-inquiries@fao.org)