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1 Introduction 
This document specifies how to read the reports sent with the eLocust2 application, and how 

to convert these reports to the format of the FAO database. The eLocust2 application offers 

three ways of collecting data: 

- by sending a report over satellite to the Novacom website. The website can then 

automatically send an email with these data to predefined addresses; 

- by saving a report on the Wescor (the small computer with which a survey officer 

enters his observations on the ground) and then downloading it later on a PC; 

- by downloading the data received on the website. 

Only the first two procedures are used with the FAO eLocust2 application. Thus, the third 

way of collecting data in not described in this document. 
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2 The Novacom platform 
The Novacom platform is a website which collects and processes the data emitted by the 

assets on the ground. It allows a user to view easily the reports sent over satellite by the locust 

survey officers, and to view on a map the position of sending of these reports. 

 

 

2.1 Connection to the platform 
Connect a PC with web access to the following URL: 

http://www.novacom-services.com 

Then click on Accès client. A login window appears: 

 

 

Select the English language. Log in with the identity delivered by the FAO, specific to your 

country. Then validate by clicking on OK. The startup page appears, with the last report sent 

by each asset. 
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On the left of the screen are the menus. By clicking on an orange item of a menu, you can 

display a submenu. If you click on a submenu, its content appears in the main screen. 

 

 

2.2 Definition of an asset 
An asset is a complete unit for the storage and the transmission of locust reports. An asset is 

mobile and belongs to one locust survey officer. An asset is composed of a Wescor (the small 

screen used by the locust survey officer to enter data) and a SAT-201 (the antenna that gets 

the GPS position and transmits reports over satellite). 

An asset can either be activated or deactivated. While activated, an asset can send data over 

satellite. While deactivated, it can only save data on the Wescor and download it on a PC. 

Both activated and deactivated assets are visible on the platform. The person in charge of the 

activation and deactivation process at the FAO is Keith Cressman. To activate or deactivate 

an asset, send a mail to keith.cressman@fao.org. 

Each country holds a given number of assets. These assets and the reports sent with these 

assets are visible on the Novacom platform. On the platform, you can consult the data of all 

the assets belonging to your country, and only these ones (not the ones belonging to the other 

countries). 

Main screen 
Menus 
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2.3 Map 
The map displays the positions of sending of the different reports. To show the map, click on 

Mapping, in the menu Consultation.  

 

 

Use the icons on the bottom of the map to navigate through it (scroll, zoom, etc.). 

The stars on the map are the most recent positions received for each asset. The name of the 

asset and the date of reception of the report are displayed next to each position. If you drag 

the mouse above a star, the details of the data associated to the report are displayed on the 

map. 

The small dots are former positions of the assets. They are linked to indicate the path 

followed by the asset. 

The three tabs in the top left corner are filters on the displayed positions. Drag the mouse 

above one of these tabs to open a menu where you can specify limitations concerning the 

reports to display on the map (you can select the reports sent in a given time period, with a 

specific equipment, etc.). 

Details of 

the report 

Report sending 

position 

Navigation bar 

Filters 
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You can hide the filters window by clicking on the up arrow in the top-right corner of the 

window. 

 

 

2.4 Data 
On the menu Analysis on the left of the screen, click on Data. A table is displayed in the main 

screen, with the data of the received reports. By default, this table contains the last report sent 

by each asset. The reports are time sorted, with one line per report, the most recent report 

being on the top. 

All the data of the reports are displayed in this table, with their date of reception by the 

platform. For one report, if a field has not been filled in by the user on the Wescor, the field is 

not displayed in the table. 

To filter the displayed data, drag the mouse on the Assets tab on the top-left corner of the 

screen. Toggle the tickboxes of the assets you want to be displayed, toggle off the others. 

Then drag the mouse on the Time period tab. For the chosen asset(s), you can either choose to 

display: 

- the reports received between two dates; 

- the N last reports; 

- the reports received during the last N hours. 

Hide arrow 
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Once you have set the filters on the assets and/or on the time period, start the filtering by 

pressing the OK button. The platform will search for a while the reports which correspond to 

the search, then the table will be displayed. 

Note: The more reports you want to display, the longer it takes for the platform to display the 

selection. The table can display a maximum of 1000 reports at the same time. If the filter you 

entered is too large, the following message is displayed: 

 

Of course, the number of values specified here (1950) is an example. If this message is 

displayed, reduce the time period or select less assets then click on OK. 

 

 

2.5 Tabs 
As a report can contain many fields of value, the data table might become a bit heavy and 

difficult to read. That is why another way to consult a report is available. Seek the report you 

want to consult, then click on the date of reception of this report in the table (the link in the 

Date / Time column). A new window appears. 

 

 

This window displays the content of the selected report. The data are classified tab by tab, 

each tab corresponding to a screen of the eLocust2 application on the Wescor. Drag the 

mouse over a tab on the top of the window to display the data corresponding to this screen. 

Only the fields that were filled in the report are displayed. If no data has been entered for a 

given tab, this tab is not displayed. 
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In the screen above, the tick boxes are toggled if the associated item was selected by the user 

on the Wescor. 
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3 Mail diffusion 
When the user of a Wescor sends a report, the latter is transmitted to the Novacom platform. 

The data can then be consulted on the website. It can also be automatically forwarded by mail 

to specific addresses registered beforehand in the platform. The mail contains a single .xml 

file containing all the data from this report. 

However, the format of this file does not fit the FAO database. That is why Novacom has 

provided a software to read the .xml file and turn it into an Excel file that can be easily 

imported in the FAO database. 

 

 

3.1 Address subscription 
To associate an email address to an asset, open the Management menu on the left of the 

screen by clicking on it, then click on the Asset item. A list of the available assets is 

displayed. Select an asset by clicking on its name in the Asset column. The menu Asset 

definition is displayed. 
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In the submenu Data dissemination, click on Add. A new line appears. In the empty field, 

enter the mail address where you want the data to be sent to. Then click on Save on the 

bottom of the screen to validate. From now on, each report received from the current asset 

will be transferred by email to the new address. The mail is also sent to the other addresses if 

more than one address has been registered for this asset. 
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3.2 Install and configure the mailReader 
The software mailReader is necessary to convert the .xml file received with the emails of the 

platform to a format adapted to the FAO database. 

 

3.2.1 Installation 

Copy the following files on your PC: 

- diffusion.dtd, 

- mailReader.xls. 

 

3.2.2 Security of the macros 

Open mailReader.xls. The window Security warning appears, asking if you want to run the 

macros or not (the macros are functions programmed in the Excel file to process data 

automatically). Click on Disable macros. 

If this window does not appear, you need to change the security level of Excel. To do so: 

1. In the menu bar, select Tools/Macro/Security. 

2. Set the security level of Excel to medium, then click on OK. 

 

3.2.3 Language 

You can change the language in which the processed data will be displayed. To do so, click 

on the Options tab on the bottom of the screen of mailReader. Next to the cell Language / 

Langue, enter English or Français. 

 

3.2.4 Local time zone 

The data processed by the software is time stamped in universal time. You need to configure 

the software so that it corrects these data and displays them in local time. To do so, change the 

value of the field Timezone / Heure locale in the Options tab. Enter the value in hours (with a 

negative value if your area is Western to the Greenwich Meridian). 

 

3.2.5 Save the settings 

In the File menu, choose Save. Then close Excel. Reopen mailReader.xls. 
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3.3 Read the reports 

3.3.1 Reception of the reports 

When you receive a mail, download the attached .xml file and put it in the directory where 

you have already put the file diffusion.dtd. You can download as many reports as you want 

and put them in the same directory. 

Run mailReader.xls. When the window Security warning appears, select Enable macros (if 

the window does not appear, you need to configure the security level of the macros (cf. § 

3.2.2: Security of the macros)). 

A browser asks you to choose the files to decode: choose the .xml file that was attached with 

the email. You can also select multiple files by dragging the mouse, or by clicking on multiple 

files while holding the Ctrl button pressed, then pressing on OK. All the selected files will be 

processed in a single shot. 

 

3.3.2 Data format 

After a while, you will see an Excel table, with one line per report. The date associated to 

each report is the date of reception of this report by the Novacom platform (given in the local 

time zone of the user of mailReader), which is short before the time it is transmitted by mail. 

 

Reports sent in two times (with additional Control data) are regrouped on the same line, with 

the date of the first sending. The eldest messages are on the top of the table, the most recent 

are on the bottom. 

The names of the fields are the same as the ones used in the database of the FAO. The names 

can be slightly different between the Novacom platform and the database of the FAO. 

 

The Novacom platform can notice the loss of data in a report. If a part of the currently read 

report has not been received by the platform, the Missing column specifies which part of the 

report has been lost. 

While processed, data is automatically saved in a .csv file in the same directory as 

mailReader. The name of the file is <day_of_processing>_SAT_<file_index>.csv. The 

former .xml data files can be removed from the PC. 

The complete format of the data is specified in the chapter 5: Data format. 

 

 

User ID Report ID  Transmission  Missing  Date Time Latitude Longitude  Area surveyed Habitat 
10 7 Sent  11/01/06 15:02:51 43.54972 1.48528 100 Dunes 
10 14 Sent Bands 30/01/06 15:47:02 43.54972 1.48500 100 Crops 
1 0 Sent  02/02/06 9:57:52 41.88222 12.48889 200 Town 
1 1 Sent  02/02/06 10:04:12 41.88222 12.48861 4 Interdunes 
1 3 Sent  02/02/06 10:30:32 41.88194 12.48889 1000 Wadi 
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4 Direct download toward a PC 
There is another way to read the data on the Wescor without using the satellite transmission 

nor the Novacom platform, but by saving the survey reports on the Wescor and downloading 

them directly to a PC. 

The current chapter explains how you can retrieve and decode old reports stored on the 

Wescor. To transfer files from the Wescor towards a computer, you have to follow the 

procedure below step by step: 

- install and configure the logReader software; 

- install the WTerm software on your computer; 

- connect the Wescor terminal to the computer; 

- put the Wescor in server mode; 

- run the WTerm application; 

- retrieve data files from the Wescor; 

- run the logReader.xls application. 

 

 

4.1 Install and configure the logReader software 

4.1.1 Installation 

Copy the file logReader.xls on your computer. 

 

4.1.2 Security of the macros 

Open logReader.xls. The window Security warning appears, asking if you want to run the 

macros or not (the macros are functions programmed in the Excel file to process data 

automatically). Click on Disable macros. 

If this window does not appear, you need to change the security level of Excel. To do so: 

1. In the menu bar, select Tools/Macro/Security. 

2. Set the security level of Excel to medium, then click on OK. 

 

4.1.3 Language 

You can change the language in which the processed data will be displayed. To do so, click 

on the Options tab on the bottom of the screen of logReader. Next to the cell Language / 

Langue, enter English or Français. 
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4.1.4 Local time zone 

The data processed by the software are in universal time. You need to configure the software 

so that it corrects these data and displays them in local time. To do so, change the value of the 

field Timezone / Heure locale in the Options tab. Enter the value in hours (with a negative 

value if your area is Western to the Greenwich Meridian). 

 

4.1.5 Save the settings 

In the File menu, choose Save. Then close Excel. Reopen logReader.xls. 

 

 

4.2 Install the WTerm software 
Create a WTerm directory on your computer, and copy the following files in: 

- Powerpak.dll, 

- WTerm.chm, 

- WTerm.exe, 

- WTerm.pdf. 

 

 

4.3 Connect the Wescor to a computer 
Establish a serial link between your computer (DB9 communication port) and the Wescor 

(DB15 port) according to the following diagram: 
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The link is done using the FAO specific cable delivered with the unit, and must be powered 

on with a tension between 9V and 30V. 

 

Wescor 
DB15 

SAT-201 Power supply 
PC 

DB9 

Power supply  
9 – 30 V 

DB15 connector DB9 connector 

Male cigar-lighter adaptor 

Female cigar-lighter adaptator 
+ 

- 

Wescor 
PC 

FAO specific cable 
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The last connector of the cable (the blue round connector towards the SAT-201) is not used 

for the downloading of files to a PC. 

 

 

4.4 Set the Wescor in server mode 
To carry out a data transfer from the Wescor, it must be set in server mode. 

As soon as the Wescor is powered on, press simultaneously the buttons PWR and CANCEL of 

the Wescor. Hold on the pressure until you hear a beep. 

The following menu then appears on the screen of the Wescor: 

 

 

Choose the option Server mode by pressing the button F3 on the Wescor. Thus, the Wescor is 

the server, and the computer is the host. You can then transfer files from the Wescor to the 

computer using WTerm. 

 
 

RDT600 BOOT OPTIONS 

Application Mode 

Server Mode 

CANCEL 

+ 

PWR 

F3 
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4.5 Use of WTerm 
Run the WTerm application (double-click on the WTerm.exe file). Below is the startup screen 

for WTerm, assuming your Wescor is powered on and correctly linked to the host: 

 

 

4.5.1 Select the communication port 

Actually, the WTerm console allows you to browse through the application installed on the 

Wescor. You can use it as a MS DOS terminal. The message on top of the console “C:\>” is 

the root of the tree structure of the Wescor. 

If you don’t see this message at the startup, you may have plugged your Wescor in a 

communication port different from COM1. To select the desired communication port on the 

host, click on the Port pick list. 

 

The default serial port is COM1. Select the desired port by clicking on it. Click on the Reset 

button. If your cable is correctly connected to the selected COM port, the message “C:\>” 

must appear. 
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4.5.2 Retrieve file 

To retrieve files from the Wescor, click on the File menu, then choose Select directory… in 

the submenu that just appeared. 

The following window appears: 

 

With the browser, choose the directory where you want your files to be stored, then click on 

OK. 

Back in the WTerm console, enter: 

cd resource 

cd data 

dir 

You should see the following files: 

- LOGMSG.TXT where the messages already sent are stored. When this file gets too big, it 

is renamed to LOGMSG.BAK, and an empty file LOGMSG.TXT is created where new 

messages will be stored. 

- LOGMSG.BAK (optional) where the older messages are stored. This file is removed when 

LOGMSG.TXT gets too big. 

- HISTORY.TXT used by the Wescor to display the logs in the History menu. 

(Note: A dummy.txt file might be visible. Do not take care of it.) 

In the File menu, select Retrieve File(s)…. The following window appears: 
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Enter logmsg.txt if you want to retrieve the most recent messages or logmsg.bak if you want 

to retrieve the oldest ones. Click on OK. A progress bar appears while the file is downloaded. 

If a file with the same name already exists on the host in the same destination directory, it is 

overwritten. 

Once the progress bar disappears, go to the destination directory on your PC, to check that the 

file you just downloaded from the Wescor is in it. 

 

 

4.6 Read the report 
Run the file logReader.xls. When the window Security warning appears, select Enable 

macros (if the window does not appear, you need to configure the security level of the macros 

(cf. § 4.1.2: Security of the macros)). 

A browser asks you to choose a file to decode: choose the file LOGMSG.TXT you have just 

downloaded from the Wescor. 

After a while, you will see an Excel table, with one line per report. The date associated to 

each report is the date of storage of the first message of a report (given in the local time zone 

of the user of logReader). The eldest messages are on the top of the table, the most recent are 

on the bottom. 

 

User ID Report ID  Transmission  Missing  Date Time Latitude  Longitude  Area surveyed Habitat 
1 0 Sent  21/02/2006 09:56:26 41.88222 12.48889 200 Town 
1 1 Sent  21/02/2006 10:02:24 41.88222 12.48861 4 Interdunes 
1 2 Saved  21/02/2006 10:09:04 41.88222 12.48861 4 Dunes 
1 3 Sent  21/02/2006 10:29:19 41.88194 12.48889 1000 Wadi 
1 4 Sent  21/02/2006 10:38:22 41.88194 12.48889 10 Dunes 
1 5 Sent  21/02/2006 10:41:56 41.88194 12.48889 34 Dunes 
 

The reports are written line by line, with one report per line. The reports sent in two times 

(with Control data apart) appear on the same line if they have been sent in less than five days 

of interval (this duration can be changed in the Options tab of logReader); otherwise they are 

considered as two distinct reports.  

If a report is sent in two times in less than five days, the date associated to the report is the 

date of sending of the first message from this report. 

For each report, the software specifies in the Transmission column if the report has also been 

sent by satellite, or only saved on the Wescor. The Missing column is always empty, indeed 

there is no transmission loss in the downloading from the Wescor to a PC. 

While processed, the data are automatically saved in a .csv file in the same directory as 

logReader. The name of the file is <day_of_processing>_PC<User ID>_<file_index>.csv. 

The former data file LOGMSG.TXT can be removed from the PC. 

The complete format of the data is specified in the chapter 5: Data format. 
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5 Data format 
Each field of data occupies one column. The order of the fields is given in the table below (it 

follows the organization on the screens of the Wescor). If a data has not been filled in for a 

report, the corresponding cell appears empty in the table. 

 

Field Possible values 

User ID ## 

Report ID ## 

Transmission Sent, Saved 

Missing Survey stop, Ecology, Bands, Hoppers, Adults, Swarms, Control 

Date dd/mm/yyyy 

Time hh:mm:ss 

Latitude +/- dd.ddddd 

Longitude +/- ddd.ddddd 

Area surveyed #### 

Habitat 
Beach, Crops, Dunes, Hills, Interdunes, Oasis, Plains, Plateau, 

Town, Wadi, Well 

Vegetation state Dry, Greening, Green, Drying 

Vegetation density Low, Medium, Dense 

Last rain date dd/mm/yyyy 

Last rain quantity Low, Moderate, High 

Soil moisture Dry, Wet 

Locust Presence Present, Absent 

To control Yes, No 

Area infested #### 

Area infested units m2, ha 

Hopper maturity H, 1, 2, 3, 4, 5, 6, F (any combo) 

Hopper phase Solitary, Transiens, Gregarious (any combo) 

Hopper behaviour Isolated, Scattered, Groups (any combo) 

Hopper density est. Low, Medium, High 

Hopper density number #### 

Hopper density units /m2, /site 

Band maturity H, 1, 2, 3, 4, 5, F (any combo) 

Band density est. Low, Medium, High 

Band density/m2 #### 

Band size ##### 

Band size units m2, ha 

Band number #### 

Adult maturity Immature, Maturing, Mature (any combo) 

Adult phase Solitary, Transiens, Gregarious (any combo) 

Adult behaviour Isolated, Scattered, Groups (any combo) 

Adult breeding Copulating, Laying (any combo) 

Adult density est. Low, Medium, High 

Transect length #### 
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Transect width ## 

Adults seen ### 

Adult density/ha 
= Adults seen / (Transect length * Transect width) * 10000. 

(The value is calculated by the software) 

Swarm maturity Immature, Maturing, Mature (any combo) 

Swarm breeding Copulating, Laying (any combo) 

Swarm density est. Low, Medium, High 

Swarm density/m2 ##### 

Swarm size #### 

Swarm size units km2, ha 

Swarm number ## 

Swarm flying FROM N, NE, E, SE, S, SW, W, NW 

Swarm flying TO N, NE, E, SE, S, SW, W, NW 

Swarm flying height Low, Medium, High 

Pesticide name 

Bendiocarb, Chlorpyrifos, Deltamethrin, Diflubenzuron, 

Fenitrothion, Fipronil, Lambdacyhalothrin, Malathion, 

Metarhizium, Teflubenzuron, Triflurnuron, Other 

Pesticide dose #.# 

Pesticide quantity ##### 

Area treated ####.# 

Control method Mechanical, Handheld, Vehicle, Air 

Control type Full cover, Barrier 

% kill ### 

Damage No, Light, Medium, Heavy 

 

The width of each column automatically fits to its content. 

For the fields with multiple choices selection, if more than one value is selected, the different 

values selected are represented in a single cell and separated by a space. The order of the 

items in the cell might vary. 

Note that the data format is exactly the same after processing with logReader and with 

mailReader. 


