Previous PageNext Page

3.2. Quick reference

The listing below provides a quick reference to the commands available in WinDisp3.5. Details of each of the WinDisp3.5 menu items are provided in sections 3.3 through 3.11 of this chapter.

File Menu

Open

Open a new window and display the selected object

Image

WinDisp or IDA image

Map

IDA or Atlas .BNA map

Bitmap

Bitmap graphic

Text

ASCII text file

Table

Comma-delimited ASCII table

Film

A series of Windows .BMP graphics displayed in succession

Project

WinDisp project

Idrisi Image

Idrisi binary image

Idrisi Vector

Idrisi vector map

Erdas Image

ERDAS 7.4 .LAN or .GIS image

ArcInfo Gen

ArcInfo .GEN arc or point map

ArcView Shape

ArcView .SHP shape map

   

Retrieve

Add the selected object to the active window

Image

WinDisp or IDA image

Bitmap

Bitmap

Map

IDA or Atlas .BNA map (use this to overlay maps on images)

Text

ASCII text file

Idrisi Image

Idrisi binary image

Idrisi Vector

Idrisi vector map

Erdas Image

ERDAS 7.4 .LAN or .GIS image

ArcInfo Gen

ArcInfo .GEN arc or point map

ArcView Shape

ArcView .SHP shape map

   

New

Open a new, empty window of the selected data type

Project

WinDisp project

Bitmap

Graphic (can be used to display images, maps, graphics, etc.)

Text

ASCII text (can also be used for color tables, data files, projects, etc.

   

Close

Close the active window

   

Close All

Close all open windows

   

Save

Save the active window to a file of the selected data type

Project

WinDisp project

Bitmap

Bitmap graphic

Text

ASCII text

   

Print

Send one or all windows to the printer

Print Current Window

Print the active text or graphic window

Print All Windows

Print all windows on a single page

Print Setup

Select a printer

   

Run

Run an external application

   

Exit

Exit WinDisp

Edit menu

Undo

Undo the previous operation

Cut

Cut a portion of a graphic or text to the clipboard

Copy

Copy a portion of a graphic or text to the clipboard

Paste

Paste contents of the clipboard to a window

Delete

Delete a portion of a graphic or text

View menu

Zoom

Zoom in/out on an image or bitmap in the active window

In

Zoom in by selecting a region with the cursor

Out

Zoom out to twice the current zoom factor

Previous

Zoom to the previous image coordinates

Image

Zoom to the full extent of the image or bitmap

Feature

Zoom in on a selected map feature

Lat/Long

Zoom in to area specified by latitude/longitude

   

Pan

Change image display up, down, left or right

Up

Move up the image 3/4ths the height of the window

Down

Move down the image 3/4ths the height of the window

Left

Move left in the image 3/4ths the window of the window

Right

Move right in the image 3/4ths the width of the window

   

Graph

Display a graph of the specified type

Image Series

Time-series for pixels selected by the cursor

Map Data

Tabular data for map features selected by the cursor

Histogram

Histogram of image pixel values

   

Redraw

Redraw the active window

Draw menu

Create the following feature in the active graphic window

Point

One or more points

Line

A line with 2 or more vertices

Region

A close polygon

Box

A rectangle which may be filled

Text

Text of a specified font and color

Fill

Fill a polygon, rectangle, etc.

Labels

Map feature names

Legend

A legend created from an existing colortable

Colorbar

A colorbar created from an existing colortable

Bitmap

A bitmap

Batch menu

Record

Record menu operations for later playback

   

Play

Play back previously recorded menu operations

   

Debug

Play back recorded batch file one line at a time

   

Stop

Stop recording or playing batch file

   

Edit

Edit a batch file in a text window

   

Variable

Assign values to batch variables

Set

Assign a value to a variable

Prompt

Ask user for a value for a variable

(List)

(This function is under construction)

   

If

Create a conditional if-then clause

Begin

Beginning of section to evaluate if clause is true

Else

Section to evaluate if clause is false

End

End of the clause

   

For

Create a for-next loop

Begin

Mark the beginning of the loop

(Each)

(This function is under construction)

End

Mark the end of the loop

   

Label

Set up a goto jump and a label to go to

Goto

Start of a goto jump

Define

End of a goto jump

   

Pause

Pause the batch file execution

   

Build List

Build an image list for processing functions

Options menu

Display

To set various display-related options

Project

Set various options related to Projects

Edit Color Table

Edit/Modify a map or image color table

Define Window Size

Define a default sub-window size (or maximize)

Communications

File-based communications link to other program

Process menu

Series

Image time-series statistics for each pixel in the images

Max

Maximum value

Min

Minimum value

Avg

Average value

Range

Range of values

Sum

Sum of values

Count

Number of valid pixels

Stddev

Standard deviation of values

Decloud

Temporal smoothing technique

Slope

Slope of trend-line of values

MaxDate

When the maximum value occurs

MinDate

When the minimum value occurs

   

Images

Various image-processing functions

Algebra

Pixel algebra on one or more images

Compress

Compress images to reduce overall size

Window

Extract a window out of an image

Filter

Max, Min, or average spatial filter for smoothing

Difference

Subtract one image from another

New

Create a new, blank image

Paste

Paste one image on top of another

Map

Fill image pixels within map polygon boundaries

Mosaic

Combine a series of images into a single image

   

Stats

Extract statistics from images for map features

Max

Maximum value

Min

Minimum value

Avg

Average value

Stddev

Standard deviation of values

Range

Range of values

Count

Number of valid pixels

   

Header

View/Edit an image header

Edit

View and edit an image header

Change Value

Change a single value in an image header

   

Threshold

Set upper and lower threshold for valid image values

   

SEDI

Satellite Enhanced Data Interpolation routines

Automatic

Automatically create interpolated image

Assisted

Automatically create interpolated image using default parameters

Step 1. Ratio File

Calculate pixel / parameter ratios

Step 2. Grid

Interpolate a Surfer grid file of ratios from the ratio file

Step 3. Image

Create an image of estimated values from gridded ratios and pixel values

   

Import

Import image, maps and color tables

IDA Luts

Convert IDA lookup table to WinDisp color table

Ascii Image

Import ASCII text file as an image

Binary Image

Import raw binary 8-bit image

Erdas Image

Import Erdas 7.4 LAN or GIS image

Erdas Trailer

Convert an ERDAS 7.4 GIS trailer to a WinDisp color table

Idrisi Image

Import Idrisi image

Idrisi Vector

Import Idrisi vector map file

Surfer Grid

Import Surfer raster grid

Surfer Plot

Import Surfer plot file as bna map file

   

Export

Export images and maps

Ascii Image

Export image to ASCII text file

Binary Image

Export image to raw, binary 8-bit image

Erdas Image

Export image to Erdas 7.4 LAN or GIS

Idrisi Image

Export image to Idrisi format

Idrisi Vector

Export bna map to Idrisi vector map file

Surfer Grid

Export image to Surfer raster grid

Surfer Blank

Export bna map file to a Surfer blanking file

   

Reproject

Convert the projection of an image

Window menu

Cascade

Cascade all open windows

Tile Horizontally

Fit all open windows down the main window

Tile Vertically

Fit all open windows across the main window

Arrange Icons

Arrange all icons across the bottom of the main window

Select

Select a window to make the active window

Define

Open and tile multiple windows within the main window

Help menu

Contents (F1)

Open this help file

About...

Display version information, etc.


Previous PageTop Of PageNext Page
This manual was prepared by the Global Information and Early Warning System of the United Nations Food and Agriculture Organization
© FAO/GIEWS - 1999
E-mail: Giews1@fao.org